Posts: 1
Joined: Sun Apr 11, 2021 11:03 am
Occupation: Parent

Human powered energy

Postby sarsheldon » Sun Apr 11, 2021 11:25 am

For my science fair project I tried doing a project on Science Buddies called Human Powered Energy. I did everything the instructions told me to but it didn't work and my LED's weren't lighting up at all. I tried looking at their help FAQ's and tried their tips but it still wouldn't light up. Here is a link to the Science Buddies project I used: ... gy#summary. Do you have any ideas why it might not work?

Posts: 476
Joined: Mon Aug 12, 2013 2:41 pm
Occupation: Science Buddies Staff

Re: Human powered energy

Postby bfinio » Mon Apr 12, 2021 10:24 am

Hi sarsheldon - a few questions that will help us troubleshoot:

1. To clarify, did you try connecting to just a single LED before you tried lighting up multiple LEDs?
2. How many turns did you make your coil?
3. Another thought that is not included in the FAQ - are you 100% sure your wire did not break somewhere in the coil? If you have access to a multimeter, you should be able to measure the resistance of the coil and it should be very low. If you get an "OL" or "1 . " reading then that means there may be a break in the wire. We have a multimeter tutorial here: ... multimeter. We didn't include this in the FAQ but it's very unlikely, but I'm trying to think of other things that could be wrong if you already tried everything in the FAQ.

Let us know and we can help you troubleshoot.



Return to “Grades 6-8: Physical Science”