hgbozzelli
Posts: 4
Joined: Fri Sep 29, 2017 1:41 pm
Occupation: Parent

Interactive Art Servo Not Working

Postby hgbozzelli » Fri Sep 29, 2017 2:00 pm

My daughter and her friend have wired the breadboard several times according to the instructions and cannot get it to work. The batteries are working and the servo. Is something off with their wiring? Any suggestions to how to get it to work? I saw some prior posts with similar problems. We have checked the 555 is correct and gone over all the directions several times. Is a step missing or incorrect in the directions?

ultramatt
Student Expert
Posts: 24
Joined: Tue Apr 26, 2016 10:04 am
Occupation: Student

Re: Interactive Art Servo Not Working

Postby ultramatt » Fri Sep 29, 2017 4:28 pm

Sorry to hear that your daughter is having a problem with the circuit.

Could send a picture of your circuit, looking straight down at it? That way we can help you troubleshoot.

When is your student's project due?

Someone from Science Buddies is going to look at the circuit and directions, but it won't be until Monday.

-Matthew

hgbozzelli
Posts: 4
Joined: Fri Sep 29, 2017 1:41 pm
Occupation: Parent

Re: Interactive Art Servo Not Working

Postby hgbozzelli » Fri Sep 29, 2017 5:25 pm

[attachment=0]Circuit pics.docx[/attachment]

That would be much appreciated. It isn't due for another week. I am having trouble uploading jpg pics so I tried an attachment.
Attachments
Circuit pics.docx
(395.72 KiB) Downloaded 91 times

bfinio
Expert
Posts: 430
Joined: Mon Aug 12, 2013 2:41 pm
Occupation: Science Buddies Staff

Re: Interactive Art Servo Not Working

Postby bfinio » Mon Oct 02, 2017 8:59 am

Hi hgbozzelli,

Sorry you're having trouble with this project. Unfortunately your pictures weren't zoomed in on the breadboard enough for me to troubleshoot your circuit. If you can try uploading more, I can try to take a look (get as close to the breadboard as possible while it remains in focus - I need to be able to clearly see which wires are in which holes).

I did test the circuit this morning and confirmed that it works if you built it according to Figures 2 and 5. However, I noticed a couple things:

- I believe there is an error in the written directions in step 17. This says to connect the 110k resistor from pin 8 to positive power. However, both diagrams show this resistor connected from pin 7 to positive power. So if you were following the diagrams you should be OK, but if you were following the written directions this could cause a problem.
- You need to cast a pretty sharp shadow on the photoresistors in order to make the servo turn. Try covering the photoresistors completely, one at a time, with your finger tip. If you are in a room with a lot of diffuse/ambient lighting, and you try holding your hand a few inches or feet away to cast a shadow, you might not be blocking enough light and the circuit won't do anything.

I am making an updated version of Figure 5 from the project that might be a little easier to follow (the current version has a bunch of extra jumper wires in it, you can make the circuit more compact by connecting more of the parts directly to the 555 chip). We will upload that when it's done so you can use it for reference, but in the meantime please let us know if either of the points above solves your problem.

Thanks,

Ben

amyc
Site Admin
Posts: 1130
Joined: Mon Dec 15, 2008 3:38 pm
Occupation: Science Buddies

Re: Interactive Art Servo Not Working

Postby amyc » Mon Oct 02, 2017 9:31 am

I have attached a copy of the circuit diagram from Ben as a PDF. If you have trouble accessing this file, please let me know, and I can email it to you instead.

Amy
Science Buddies
interactive-art-circuit.pdf
(69.6 KiB) Downloaded 199 times

hgbozzelli
Posts: 4
Joined: Fri Sep 29, 2017 1:41 pm
Occupation: Parent

Re: Interactive Art Servo Not Working

Postby hgbozzelli » Tue Oct 03, 2017 4:15 am

Thank you so much. We will try this. A few questions on your diagram:
-the directions say the capacitor should be in row one and two. In the diagram it appears to be in row 1 and row 1 negative not anywhere in row 2
- step 9: connecting the servo motor red lead to chip pin 4, the lead from the servo motor is shown in the diagram going directly into the positive side of the breadboard. Is this connected through the single wire in row 4 and positive? Why isn’t the red servo wire directly into row 4 per item #9?

Appreciate your help

bfinio
Expert
Posts: 430
Joined: Mon Aug 12, 2013 2:41 pm
Occupation: Science Buddies Staff

Re: Interactive Art Servo Not Working

Postby bfinio » Tue Oct 03, 2017 5:02 am

Hi hgbozzelli,

Good eye! Electrically, these connections are equivalent, and this is related to how the holes are connected internally on a breadboard. If you haven't already, it might help a lot to watch the video at the top of our How to Use a Breadboard tutorial:

https://www.sciencebuddies.org/science- ... breadboard

and read this part of the tutorial and look at the pictures (from here all the way down to, and including, the "How are the Holes Connected?" section):

https://www.sciencebuddies.org/science- ... breadboard

In this specific case, you will notice that:

- Pin 1 of the chip is connected to "ground" (the long set of holes next to the blue line on the left side of the breadboard, called a "bus") with a jumper wire. That means it doesn't matter whether you connect one side of the capacitor directly to pin 1, or to the ground bus. They are electrically connected, so as far as the circuit is concerned, the connection is the same - even if the physical layout looks different.
- Similarly, chip pin 4 is connected to "power" (the bus with the red line). So again, it doesn't make a difference whether you connect the servo motor's wire directly to in 4, or to the power bus. They're electrically connected so it accomplishes the same thing.

I have updated the written instructions to correspond better to the new diagram, but those changes aren't live on the site yet. I will upload those as a PDF later today so you can have access to them now.

Thanks,

Ben

bfinio
Expert
Posts: 430
Joined: Mon Aug 12, 2013 2:41 pm
Occupation: Science Buddies Staff

Re: Interactive Art Servo Not Working

Postby bfinio » Tue Oct 03, 2017 5:43 am

Here are the instructions that should match the new circuit diagram.
Attachments
new instructions.pdf
(485.41 KiB) Downloaded 83 times

hgbozzelli
Posts: 4
Joined: Fri Sep 29, 2017 1:41 pm
Occupation: Parent

Re: Interactive Art Servo Not Working

Postby hgbozzelli » Tue Oct 03, 2017 5:55 am

Thank you so much for all the help.


Return to “Grades K-5: Physical Science”